import re
regex = re.compile(r"#(').*(')", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("#'The universe is big, it's vast and complicated, and ridiculous and sometimes, very rarely, impossible things just happen and we call them miracles.'\n"
"'I am and always will be the optimist. The hoper of far-flung hopes and the dreamer of improbable dreams.'\n"
"#'No, hold on. Sorry, that's the 'The Lion King'.'\n"
"#'What's the point in two hearts if you can't be a bit forgiving now and then?'\n"
"'You know that in 900 years in time and space I've never met anyone who wasn't important before.'\n"
"#'You want weapons? We're in a library! Books! Best weapons in the world!'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")