const regex = new RegExp('#(\\').*(\\')', 'gmi')
const str = `#'The universe is big, it's vast and complicated, and ridiculous and sometimes, very rarely, impossible things just happen and we call them miracles.'
'I am and always will be the optimist. The hoper of far-flung hopes and the dreamer of improbable dreams.'
#'No, hold on. Sorry, that's the 'The Lion King'.'
#'What's the point in two hearts if you can't be a bit forgiving now and then?'
'You know that in 900 years in time and space I've never met anyone who wasn't important before.'
#'You want weapons? We're in a library! Books! Best weapons in the world!'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}