import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(').*(')";
final String string = "#'The universe is big, it's vast and complicated, and ridiculous and sometimes, very rarely, impossible things just happen and we call them miracles.'\n"
+ "'I am and always will be the optimist. The hoper of far-flung hopes and the dreamer of improbable dreams.'\n"
+ "#'No, hold on. Sorry, that's the 'The Lion King'.'\n"
+ "#'What's the point in two hearts if you can't be a bit forgiving now and then?'\n"
+ "'You know that in 900 years in time and space I've never met anyone who wasn't important before.'\n"
+ "#'You want weapons? We're in a library! Books! Best weapons in the world!'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}