using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" imageNamed:NSLocalizedString\((@""[^""]*[\u4E00-\u9FA5]+[^""\n]*?""), nil\)";
string input = @"[UIImage imageNamed:NSLocalizedString(@""你好"", nil)]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}