const regex = / imageNamed:NSLocalizedString\((@"[^"]*[\u4E00-\u9FA5]+[^"\n]*?"), nil\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' imageNamed:NSLocalizedString\\((@"[^"]*[\\u4E00-\\u9FA5]+[^"\\n]*?"), nil\\)', 'gm')
const str = `[UIImage imageNamed:NSLocalizedString(@"你好", nil)]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}