using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:@pattern\s+)?(?:@color\s+)?@product(?:\s+with @[A-Z,a-z]+)?";
string input = @"I am looking for a @color @product with @pattern and @pattern @color @product.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}