re = /(?:@pattern\s+)?(?:@color\s+)?@product(?:\s+with @[A-Z,a-z]+)?/m
str = 'I am looking for a @color @product with @pattern and @pattern @color @product.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end