// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:@pattern\s+)?(?:@color\s+)?@product(?:\s+with @[A-Z,a-z]+)?").unwrap();
let string = "I am looking for a @color @product with @pattern and @pattern @color @product.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}