using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bnew\s+Alert\((?:(?!\.showAndWait\(\);\s*$)[\s\S])*""\);";
string input = @"new Alert(AlertType.INFORMATION, ""This alert should not be matched"").showAndWait();
new Alert(AlertType.INFORMATION, ""This alert should be matched"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}