re = /\bnew\s+Alert\((?:(?!\.showAndWait\(\);\s*$)[\s\S])*"\);/m
str = 'new Alert(AlertType.INFORMATION, "This alert should not be matched").showAndWait();
new Alert(AlertType.INFORMATION, "This alert should be matched");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end