import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bnew\\s+Alert\\((?:(?!\\.showAndWait\\(\\);\\s*$)[\\s\\S])*\"\\);";
final String string = "new Alert(AlertType.INFORMATION, \"This alert should not be matched\").showAndWait();\n\n"
+ "new Alert(AlertType.INFORMATION, \"This alert should be matched\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}