const regex = /xyz((?!abc).)*?123/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('xyz((?!abc).)*?123', 'gms')
const str = `abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}