$re = '/xyz((?!abc).)*?123/ms';
$str = 'abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);