import re
regex = re.compile(r"xyz((?!abc).)*?123", flags=re.MULTILINE | re.DOTALL)
test_str = ("abc----1\n"
"pqr----2\n"
"123----3\n"
"xyz----4\n"
"lll----5\n"
"pqr----6\n"
"123----7\n"
"qqq----8\n"
"xyz----5\n"
"abc----3\n"
"123----9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")