re = /xyz((?!abc).)*?123/m
str = 'abc----1
pqr----2
123----3
xyz----4
lll----5
pqr----6
123----7
qqq----8
xyz----5
abc----3
123----9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end