using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[PC]\(\d+(?:,| +)\s*\d+\)";
string input = @"C(1, 2) or P(2 3) //expected to match
C(43) or C(43, ) // expect not to match
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}