$re = '/[PC]\(\d+(?:,| +)\s*\d+\)/m';
$str = 'C(1, 2) or P(2 3) //expected to match
C(43) or C(43, ) // expect not to match
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);