// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[PC]\(\d+(?:,| +)\s*\d+\)").unwrap();
let string = "C(1, 2) or P(2 3) //expected to match
C(43) or C(43, ) // expect not to match
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}