package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[PC]\(\d+(?:,| +)\s*\d+\)`)
var str = `C(1, 2) or P(2 3) //expected to match
C(43) or C(43, ) // expect not to match
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}