import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^\\sa-z])\\d+(?![^\\sa-z])";
final String string = "15x20x30 -> 'values': [15,20,30]\n"
+ "15bits -> 'values': [15]\n"
+ "15 -> 'values': [15]\n"
+ "x15 -> 'values': [15]\n\n"
+ "but should not match:\n\n"
+ "456.48\n"
+ "888,12\n"
+ "6,4.8,4684.,6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}