use strict;
my $str = '15x20x30 -> \'values\': [15,20,30]
15bits -> \'values\': [15]
15 -> \'values\': [15]
x15 -> \'values\': [15]
but should not match:
456.48
888,12
6,4.8,4684.,6';
my $regex = qr/(?<![^\sa-z])\d+(?![^\sa-z])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}