$re = '/(?<![^\sa-z])\d+(?![^\sa-z])/m';
$str = '15x20x30 -> \'values\': [15,20,30]
15bits -> \'values\': [15]
15 -> \'values\': [15]
x15 -> \'values\': [15]
but should not match:
456.48
888,12
6,4.8,4684.,6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);