#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Offset:[ ]+(10{0,2}(?:,0{3})?|10?(?:,0{3}){2})(?![,\d])"
Local $sString = "abdc Offset: 1 some more text" & @CRLF & _
"abdc Offset: 10 some more text" & @CRLF & _
"abdc Offset: 100 some more text" & @CRLF & _
"abdc Offset: 1,000 some more text" & @CRLF & _
"abdc Offset: 10,000 some more text" & @CRLF & _
"abdc Offset: 100,000 some more text" & @CRLF & _
"abdc Offset: 1,000,000 some more text" & @CRLF & _
"abdc Offset: 10,000,000 some more text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")