$re = '/Offset:[ ]+(10{0,2}(?:,0{3})?|10?(?:,0{3}){2})(?![,\d])/';
$str = 'abdc Offset: 1 some more text
abdc Offset: 10 some more text
abdc Offset: 100 some more text
abdc Offset: 1,000 some more text
abdc Offset: 10,000 some more text
abdc Offset: 100,000 some more text
abdc Offset: 1,000,000 some more text
abdc Offset: 10,000,000 some more text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);