package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),(.*)$`)
var str = `fskfkjfjaslfk,fsldfsd,sfklja;lskfjlasf`
var substitution = "$"
fmt.Println(re.ReplaceAllString(str, substitution))
}