use strict;
my $str = 'fskfkjfjaslfk,fsldfsd,sfklja;lskfjlasf';
my $regex = qr/,(.*)$/mp;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";