import re
regex = re.compile(r",(.*)$", flags=re.MULTILINE)
test_str = "fskfkjfjaslfk,fsldfsd,sfklja;lskfjlasf"
subst = "$"
result = regex.sub(subst, test_str)
if result:
print(result)