$re = '/,(.*)$/m';
$str = 'fskfkjfjaslfk,fsldfsd,sfklja;lskfjlasf';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;