#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([0-3]\d)/(0[4-9]|1[012]))/1999"
Local $sString = "01/03/1999 too early" & @CRLF & _
"30/03/1999 too early" & @CRLF & _
"01/04/1999" & @CRLF & _
"31/04/1999 invalid date (month-specific)" & @CRLF & _
"35/04/1999 invalid date" & @CRLF & _
"30/05/1999" & @CRLF & _
"31/05/1999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")