package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([0-3]\d)/(0[4-9]|1[012]))/1999`)
var str = `01/03/1999 too early
30/03/1999 too early
01/04/1999
31/04/1999 invalid date (month-specific)
35/04/1999 invalid date
30/05/1999
31/05/1999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}