// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([0-3]\d)/(0[4-9]|1[012]))/1999").unwrap();
let string = "01/03/1999 too early
30/03/1999 too early
01/04/1999
31/04/1999 invalid date (month-specific)
35/04/1999 invalid date
30/05/1999
31/05/1999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}