import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|\\W)106(?=$|\\W)";
final String string = "No match:\n"
+ "106M\n"
+ "1106\n"
+ "106in a string is bad even if it starts the line\n"
+ "And it may finish with the target but not as the tail of a string106\n\n"
+ "Match:\n"
+ "106 something else\n"
+ "another 106\n"
+ "And ofcouse \"106' will work as well\n"
+ "I just want 106 to show up but not embedded in other numbers or text\n"
+ "but it's OK is the end of the line is 106\n"
+ "106 may also start the line but";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}