import re
regex = re.compile(r"(?<=^|\W)106(?=$|\W)", flags=re.MULTILINE)
test_str = ("No match:\n"
"106M\n"
"1106\n"
"106in a string is bad even if it starts the line\n"
"And it may finish with the target but not as the tail of a string106\n\n"
"Match:\n"
"106 something else\n"
"another 106\n"
"And ofcouse \"106' will work as well\n"
"I just want 106 to show up but not embedded in other numbers or text\n"
"but it's OK is the end of the line is 106\n"
"106 may also start the line but")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")