const regex = /(?<=^|\W)106(?=$|\W)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\W)106(?=$|\\W)', 'gm')
const str = `No match:
106M
1106
106in a string is bad even if it starts the line
And it may finish with the target but not as the tail of a string106
Match:
106 something else
another 106
And ofcouse "106' will work as well
I just want 106 to show up but not embedded in other numbers or text
but it's OK is the end of the line is 106
106 may also start the line but`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}