$re = '/(?<=^|\W)106(?=$|\W)/m';
$str = 'No match:
106M
1106
106in a string is bad even if it starts the line
And it may finish with the target but not as the tail of a string106
Match:
106 something else
another 106
And ofcouse "106\' will work as well
I just want 106 to show up but not embedded in other numbers or text
but it\'s OK is the end of the line is 106
106 may also start the line but';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);