$re = '/\{(?<nested>[^{}]+\{[^{}]+\}[^{}]+)\}/';
$str = '\\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text}\\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\textbf{Other text} \\section{Welcome to $\\mathbb{R}^n$} \\textbf{Other text}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);