#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)b\/\*?[\u4e00-\u9fa5a-zA-Z]+\**$"
Local $sString = "b/王小明" & @CRLF & _
"b/Mr王" & @CRLF & _
"b/王小明*" & @CRLF & _
"b/王小*" & @CRLF & _
"b/*王小" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")