use strict;
my $str = 'b/王小明
b/Mr王
b/王小明*
b/王小*
b/*王小
';
my $regex = qr/b\/\*?[\u4e00-\u9fa5a-zA-Z]+\**$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}