using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"b\/\*?[\u4e00-\u9fa5a-zA-Z]+\**$";
string input = @"b/王小明
b/Mr王
b/王小明*
b/王小*
b/*王小
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}