import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<flag>#+)\\s*(?<content>.*?)\\s*$";
final String string = "# The quick brown (1) \n"
+ "## fox jumps (1a)\n"
+ "###over (1a1)\n"
+ "###the (1a2)\n"
+ "## lazy dog (1b)\n"
+ "# Foo bar (2)\n"
+ "# Baz biz (3)\n"
+ "##buzz (3a) \n"
+ "##booz (3b) \n"
+ "# Lorem ipsum (4)\n"
+ "## ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}