# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<flag>#+)\s*(?<content>.*?)\s*$"
test_str = ("# The quick brown (1) \n"
"## fox jumps (1a)\n"
"###over (1a1)\n"
"###the (1a2)\n"
"## lazy dog (1b)\n"
"# Foo bar (2)\n"
"# Baz biz (3)\n"
"##buzz (3a) \n"
"##booz (3b) \n"
"# Lorem ipsum (4)\n"
"## ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.