// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<flag>#+)\s*(?<content>.*?)\s*$").unwrap();
let string = "# The quick brown (1)
## fox jumps (1a)
###over (1a1)
###the (1a2)
## lazy dog (1b)
# Foo bar (2)
# Baz biz (3)
##buzz (3a)
##booz (3b)
# Lorem ipsum (4)
## ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}