re = /^(?<flag>#+)\s*(?<content>.*?)\s*$/m
str = '# The quick brown (1)
## fox jumps (1a)
###over (1a1)
###the (1a2)
## lazy dog (1b)
# Foo bar (2)
# Baz biz (3)
##buzz (3a)
##booz (3b)
# Lorem ipsum (4)
## '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end