import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"article\">(.+?)^<\\/div>";
final String string = "<div class=\"article\">\n"
+ " <p class=\"title\">Test!</p>\n"
+ " <div>Content content</div>\n"
+ " <p>test test</p>\n"
+ " <div class=\"test\">test</div>\n"
+ " <p>test</p>\n"
+ "</div>\n"
+ "<?= rand(0,100); ?>\n"
+ "<div class=\"article\">\n"
+ " <p class=\"title\">Test1!</p>\n"
+ " <div>Content content1</div>\n"
+ " <p>test test1</p>\n"
+ " <div class=\"test\">test1</div>\n"
+ " <p>test1</p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}