import re
regex = re.compile(r"<div class=\"article\">(.+?)^<\/div>", flags=re.MULTILINE | re.DOTALL)
test_str = ("<div class=\"article\">\n"
" <p class=\"title\">Test!</p>\n"
" <div>Content content</div>\n"
" <p>test test</p>\n"
" <div class=\"test\">test</div>\n"
" <p>test</p>\n"
"</div>\n"
"<?= rand(0,100); ?>\n"
"<div class=\"article\">\n"
" <p class=\"title\">Test1!</p>\n"
" <div>Content content1</div>\n"
" <p>test test1</p>\n"
" <div class=\"test\">test1</div>\n"
" <p>test1</p>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")