import Foundation
let pattern = #"<div class="article">(.+?)^<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<div class="article">
<p class="title">Test!</p>
<div>Content content</div>
<p>test test</p>
<div class="test">test</div>
<p>test</p>
</div>
<?= rand(0,100); ?>
<div class="article">
<p class="title">Test1!</p>
<div>Content content1</div>
<p>test test1</p>
<div class="test">test1</div>
<p>test1</p>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)