using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0\.([0-7]\d*|8[0-4]\d*|85[0-6]\d*)";
string input = @"0.641
0.832
0.853
0.857
0.858
0.867
0.957";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}