// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)0\.([0-7]\d*|8[0-4]\d*|85[0-6]\d*)").unwrap();
let string = "0.641
0.832
0.853
0.857
0.858
0.867
0.957";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}