const regex = /0\.([0-7]\d*|8[0-4]\d*|85[0-6]\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0\\.([0-7]\\d*|8[0-4]\\d*|85[0-6]\\d*)', 'gm')
const str = `0.641
0.832
0.853
0.857
0.858
0.867
0.957`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}