$re = '/0\.([0-7]\d*|8[0-4]\d*|85[0-6]\d*)/m';
$str = '0.641
0.832
0.853
0.857
0.858
0.867
0.957';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);